Webb AB1476 pics before restauration and advice

3 posts / 0 new
Last post
Henno
Henno's picture
Offline
Last seen: 4 hours 5 min ago
Joined: 18/02/2019 - 10:29
Webb AB1476 pics before restauration and advice

Hi,

After restoring the Commodore B17 and selling it on, I stumbled across a Webb, which was close to me, on the way by accident, and a place in the shed to fill it with.

Anyway, at the moment it looks not to bad, needs some paint, general TLC, but it does not start, no spark. The spark plug is new, take off the flywheel en check te points and condenser? What the consensus on this; change it to electronic ignition via a B&S 591420 kit? The engine is 60102 0374 03 81120303, so that's from 3 December '81.

Another thing is that the grass box is a bit chewed on by the cylinder, anyone any experience in restoring / fixing this?

 

wristpin
wristpin's picture
Offline
Last seen: 2 hours 29 min ago
Joined: 23/05/2012 - 22:09
The top part of the label on

The top part of the label on the blower housing is a bit scuffed but does it say Magnetron? With an 81 build date there's a fair chance that it is already Magnetron (electronic) ignition.

Remove the blower housing and post an image of the coil to settle the matter. If it's not, and you want to go electronic i wouldn't mess around with the clip on module; just source a new or used Magnetron coil

I've never had much luck with "plastic welding", either DIY or expensive  "professional" efforts. Usually resorted to shaped alloy patches and pop rivets! You could try Q Bond  - good for some plastics but once the adhesive has been opened it tend to go off in a month or so.  

Henno
Henno's picture
Offline
Last seen: 4 hours 5 min ago
Joined: 18/02/2019 - 10:29
Good morning wristpin, 

Good morning wristpin, 

The blower housing does not read magnetron, just "Easy spin starting". Will remove the cover soon and post a photo.

 

Regards, Henno