Skip to main content
Collection, Preservation and Display of Old Lawn Mowers

Atco medium weight (PROBLEM!!!)

HELLO ALL

I HAVE A PROBLEM WITH MY ATCO MEDIUM WEIGHT LAWN MOWER.

I KICK START IT (USING A LODGE C3 SPARK PLUG) AND IT STARTS FINE.

IF I LEAVE IT, IT WILL TICK OVER FOR AGES, BUT AS SOON AS I REV IT UP ON THE THROTTLE A LITTLE BIT, THE MOWER GOES CRAZY!!!!

IT KEEPS ON REVING LOUDER AND LOUDER AND LOUDER, FASTER AND FASTER AND FASTER, UNTIL IT SOUNDS LIKE IT IS GOING TO EXPLODE.

IS IT STRUGGLING TO FIND PETROL?

IS THE PETROL/ OIL MIX WRONG?

ANY HELP WOULD BE APPRECIATED GREATLY

MANY THANKS, DANIEL

wristpin Wed, 06/11/2013

Possibly gets LOUDER and LOUDER because you are SHOUTING!!!  Caps not required!!

How about an image of the carb side of the engine so that we can see exactly what you have got?

drharlow55 Thu, 07/11/2013

In reply to by wristpin

Here are some pictures of the lawnmower in question. Capital letters are switched off this time.

file:///C:/Users/pigeonman/20131107_134331.jpg

file:///C:/Users/pigeonman/20131107_134415.jpg

file:///C:/Users/pigeonman/20131107_134437.jpg

file:///C:/Users/pigeonman/20131107_134509.jpg

file:///C:/Users/pigeonman/20131107_134529.jpg

file:///C:/Users/pigeonman/20131107_134537.jpg

file:///C:/Users/pigeonman/20131107_134546.jpg

If this does not work please let me know how to put pictures on here.

topgunhorse Thu, 14/11/2013

Try unscrewing the cap where the throttle cable enters. There should be spring that pushes the piston and needle back down. Sounds like it is sticking open.